import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\"[^\"]*\"[^\"]*)*?\\\"{1}([^\"]*?([']{1,})[^\"]*?)\\\"";
final String string = "If you place a quote there: () it should not be detected, but if \"you place a quote there: (()) \" it should be detected , apparently if there is no quote between double-quotes elsewhere and there are some outside double-quotes ex: () those outside are detected and we do not want that.\n\n"
+ "My problem is that I want to match single quotes using a regex, but I only want to do so if they are being quotes : between double-quotes, like so : \"(())\" add/remove single quotes between parenthesis to test...\n\n"
+ "(()) = should match\n"
+ "() = should not match";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}