import re
regex = re.compile(r"(?:\"[^\"]*\"[^\"]*)*?\"{1}([^\"]*?([']{1,})[^\"]*?)\"")
test_str = ("If you place a quote there: () it should not be detected, but if \"you place a quote there: (()) \" it should be detected , apparently if there is no quote between double-quotes elsewhere and there are some outside double-quotes ex: () those outside are detected and we do not want that.\n\n"
"My problem is that I want to match single quotes using a regex, but I only want to do so if they are being quotes : between double-quotes, like so : \"(())\" add/remove single quotes between parenthesis to test...\n\n"
"(()) = should match\n"
"() = should not match")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")