// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?:"[^"]*"[^"]*)*?\"{1}([^"]*?([']{1,})[^"]*?)\""#).unwrap();
let string = "If you place a quote there: () it should not be detected, but if \"you place a quote there: (()) \" it should be detected , apparently if there is no quote between double-quotes elsewhere and there are some outside double-quotes ex: () those outside are detected and we do not want that.
My problem is that I want to match single quotes using a regex, but I only want to do so if they are being quotes : between double-quotes, like so : \"(())\" add/remove single quotes between parenthesis to test...
(()) = should match
() = should not match";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}