use strict;
my $str = 'If you place a quote there: () it should not be detected, but if "you place a quote there: (()) " it should be detected , apparently if there is no quote between double-quotes elsewhere and there are some outside double-quotes ex: () those outside are detected and we do not want that.
My problem is that I want to match single quotes using a regex, but I only want to do so if they are being quotes : between double-quotes, like so : "(())" add/remove single quotes between parenthesis to test...
(()) = should match
() = should not match';
my $regex = qr/(?:"[^"]*"[^"]*)*?\"{1}([^"]*?([']{1,})[^"]*?)\"/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}