#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(\w+)\s+([а-яА-Я]+)"
Local $sString = "Когда: 14 августа - 16 августа, 12:00" & @CRLF & _
"Когда: 3 августа - 30 сентября, с 10:00 по 22:30" & @CRLF & _
"Когда: 22 декабря, 12:00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")