// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(\w+)\s+([а-яА-Я]+)").unwrap();
let string = "Когда: 14 августа - 16 августа, 12:00
Когда: 3 августа - 30 сентября, с 10:00 по 22:30
Когда: 22 декабря, 12:00";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}