const regex = /(\w+)\s+([а-яА-Я]+)/mi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+)\\s+([а-яА-Я]+)', 'mi')
const str = `Когда: 14 августа - 16 августа, 12:00
Когда: 3 августа - 30 сент ября, с 10:00 по 22:30
Когда: 22 декабря, 12:00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}