using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)\s+([а-яА-Я]+)";
string input = @"Когда: 14 августа - 16 августа, 12:00
Когда: 3 августа - 30 сентября, с 10:00 по 22:30
Когда: 22 декабря, 12:00";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}