package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(\w+)\s+([а-яА-Я]+)`)
var str = `Когда: 14 августа - 16 августа, 12:00
Когда: 3 августа - 30 сентября, с 10:00 по 22:30
Когда: 22 декабря, 12:00`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}