re = /(\w+)\s+([а-яА-Я]+)/mi
str = 'Когда: 14 августа - 16 августа, 12:00
Когда: 3 августа - 30 сентября, с 10:00 по 22:30
Когда: 22 декабря, 12:00'
# Print the match result
str.match(re) do |match|
puts match.to_s
end