$re = '/(\w+)\s+([а-яА-Я]+)/mi';
$str = 'Когда: 14 августа - 16 августа, 12:00
Когда: 3 августа - 30 сентября, с 10:00 по 22:30
Когда: 22 декабря, 12:00';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);