#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.{12,14}$)(?!([a-zA-Z\d])(?:&?\1)+$)[a-zA-Z\d]+(?:&[a-zA-Z\d]+)?$"
Local $sString = "ABC123567GHDG4" & @CRLF & _
"ABC1235&67GHD" & @CRLF & _
"ABCDEFGHIJKLR" & @CRLF & _
"1254789563254" & @CRLF & _
"125478&563254" & @CRLF & _
"" & @CRLF & _
"125478556325&" & @CRLF & _
"&125478556325" & @CRLF & _
"ABCDEFGHIJKL&" & @CRLF & _
"&ABCDEFGHIJKL"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")