re = /^(?=.{12,14}$)(?!([a-zA-Z\d])(?:&?\1)+$)[a-zA-Z\d]+(?:&[a-zA-Z\d]+)?$/m
str = 'ABC123567GHDG4
ABC1235&67GHD
ABCDEFGHIJKLR
1254789563254
125478&563254
125478556325&
&125478556325
ABCDEFGHIJKL&
&ABCDEFGHIJKL'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end