const regex = new RegExp('^(?=.{12,14}$)(?!([a-zA-Z\\d])(?:&?\\1)+$)[a-zA-Z\\d]+(?:&[a-zA-Z\\d]+)?$', 'gm')
const str = `ABC123567GHDG4
ABC1235&67GHD
ABCDEFGHIJKLR
1254789563254
125478&563254
125478556325&
&125478556325
ABCDEFGHIJKL&
&ABCDEFGHIJKL`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}