$re = '/^(?=.{12,14}$)(?!([a-zA-Z\d])(?:&?\1)+$)[a-zA-Z\d]+(?:&[a-zA-Z\d]+)?$/m';
$str = 'ABC123567GHDG4
ABC1235&67GHD
ABCDEFGHIJKLR
1254789563254
125478&563254
125478556325&
&125478556325
ABCDEFGHIJKL&
&ABCDEFGHIJKL';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);