import re
regex = re.compile(r"^(?=.{12,14}$)(?!([a-zA-Z\d])(?:&?\1)+$)[a-zA-Z\d]+(?:&[a-zA-Z\d]+)?$", flags=re.MULTILINE)
test_str = ("ABC123567GHDG4\n"
"ABC1235&67GHD\n"
"ABCDEFGHIJKLR\n"
"1254789563254\n"
"125478&563254\n\n"
"125478556325&\n"
"&125478556325\n"
"ABCDEFGHIJKL&\n"
"&ABCDEFGHIJKL")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")