import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{12,14}$)(?!([a-zA-Z\\d])(?:&?\\1)+$)[a-zA-Z\\d]+(?:&[a-zA-Z\\d]+)?$";
final String string = "ABC123567GHDG4\n"
+ "ABC1235&67GHD\n"
+ "ABCDEFGHIJKLR\n"
+ "1254789563254\n"
+ "125478&563254\n\n"
+ "125478556325&\n"
+ "&125478556325\n"
+ "ABCDEFGHIJKL&\n"
+ "&ABCDEFGHIJKL";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}