use strict;
my $str = 'ABC123567GHDG4
ABC1235&67GHD
ABCDEFGHIJKLR
1254789563254
125478&563254
125478556325&
&125478556325
ABCDEFGHIJKL&
&ABCDEFGHIJKL';
my $regex = qr/^(?=.{12,14}$)(?!([a-zA-Z\d])(?:&?\1)+$)[a-zA-Z\d]+(?:&[a-zA-Z\d]+)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}