#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([A-Z]?[a-z ]+) (.*)"
Local $sString = "Pump sectional CNS-300-400" & @CRLF & _
"Electric motor AC-600 №130" & @CRLF & _
"Switching vacuum breaker 1 BM-600 3000" & @CRLF & _
"Transformator TMG-CAT-340-748"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")