package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([A-Z]?[a-z ]+) (.*)`)
var str = `Pump sectional CNS-300-400
Electric motor AC-600 №130
Switching vacuum breaker 1 BM-600 3000
Transformator TMG-CAT-340-748`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}