use strict;
my $str = 'Pump sectional CNS-300-400
Electric motor AC-600 №130
Switching vacuum breaker 1 BM-600 3000
Transformator TMG-CAT-340-748';
my $regex = qr/([A-Z]?[a-z ]+) (.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}