using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Z]?[a-z ]+) (.*)";
string input = @"Pump sectional CNS-300-400
Electric motor AC-600 №130
Switching vacuum breaker 1 BM-600 3000
Transformator TMG-CAT-340-748";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}