re = /([A-Z]?[a-z ]+) (.*)/m
str = 'Pump sectional CNS-300-400
Electric motor AC-600 №130
Switching vacuum breaker 1 BM-600 3000
Transformator TMG-CAT-340-748'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end