import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z]?[a-z ]+) (.*)";
final String string = "Pump sectional CNS-300-400\n"
+ "Electric motor AC-600 №130\n"
+ "Switching vacuum breaker 1 BM-600 3000\n"
+ "Transformator TMG-CAT-340-748";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}