# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/("price"\s?:\s?"(?:\d+\.?)+)(\s?€)"/$1"/gm;t' <<< "[
{
\"price\":\"120.000 €\",
\"donotreplace\": \"120.000 €\"
},
{
\"price\": \"42.120.000 €\",
\"donotreplace\": \"42.120.000 €\"
},
{
\"price\" : \"42 €\",
\"donotreplace\": \"42.120.000 €\"
},
{
\"price\":\"42\",
\"donotreplace\": \"42.120.000 €\"
},
{
\"price\":\"42€\",
\"donotreplace\": \"42.120.000 €\"
},
]
"