import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\"price\"\\s?:\\s?\"(?:\\d+\\.?)+)(\\s?€)\"";
final String string = "[\n"
+ "{\n"
+ "\"price\":\"120.000 €\",\n"
+ "\"donotreplace\": \"120.000 €\"\n"
+ "},\n"
+ "{\n"
+ "\"price\": \"42.120.000 €\",\n"
+ "\"donotreplace\": \"42.120.000 €\"\n"
+ "},\n"
+ "{\n"
+ "\"price\" : \"42 €\",\n"
+ "\"donotreplace\": \"42.120.000 €\"\n"
+ "},\n"
+ "{\n"
+ "\"price\":\"42\",\n"
+ "\"donotreplace\": \"42.120.000 €\"\n"
+ "},\n"
+ "{\n"
+ "\"price\":\"42€\",\n"
+ "\"donotreplace\": \"42.120.000 €\"\n"
+ "},\n"
+ "]\n";
final String subst = "$1\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}