package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)("price"\s?:\s?"(?:\d+\.?)+)(\s?€)"`)
var str = `[
{
"price":"120.000 €",
"donotreplace": "120.000 €"
},
{
"price": "42.120.000 €",
"donotreplace": "42.120.000 €"
},
{
"price" : "42 €",
"donotreplace": "42.120.000 €"
},
{
"price":"42",
"donotreplace": "42.120.000 €"
},
{
"price":"42€",
"donotreplace": "42.120.000 €"
},
]
`
var substitution = "$1""
fmt.Println(re.ReplaceAllString(str, substitution))
}