use strict;
my $str = '[
{
"price":"120.000 €",
"donotreplace": "120.000 €"
},
{
"price": "42.120.000 €",
"donotreplace": "42.120.000 €"
},
{
"price" : "42 €",
"donotreplace": "42.120.000 €"
},
{
"price":"42",
"donotreplace": "42.120.000 €"
},
{
"price":"42€",
"donotreplace": "42.120.000 €"
},
]
';
my $regex = qr/("price"\s?:\s?"(?:\d+\.?)+)(\s?€)"/mp;
my $subst = '$1"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";