const regex = /("price"\s?:\s?"(?:\d+\.?)+)(\s?€)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('("price"\\s?:\\s?"(?:\\d+\\.?)+)(\\s?€)"', 'gm')
const str = `[
{
"price":"120.000 €",
"donotreplace": "120.000 €"
},
{
"price": "42.120.000 €",
"donotreplace": "42.120.000 €"
},
{
"price" : "42 €",
"donotreplace": "42.120.000 €"
},
{
"price":"42",
"donotreplace": "42.120.000 €"
},
{
"price":"42€",
"donotreplace": "42.120.000 €"
},
]
`;
const subst = `$1"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);