re = /("price"\s?:\s?"(?:\d+\.?)+)(\s?€)"/m
str = '[
{
"price":"120.000 €",
"donotreplace": "120.000 €"
},
{
"price": "42.120.000 €",
"donotreplace": "42.120.000 €"
},
{
"price" : "42 €",
"donotreplace": "42.120.000 €"
},
{
"price":"42",
"donotreplace": "42.120.000 €"
},
{
"price":"42€",
"donotreplace": "42.120.000 €"
},
]
'
subst = '$1"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result