import Foundation
let pattern = #"("price"\s?:\s?"(?:\d+\.?)+)(\s?€)""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[
{
"price":"120.000 €",
"donotreplace": "120.000 €"
},
{
"price": "42.120.000 €",
"donotreplace": "42.120.000 €"
},
{
"price" : "42 €",
"donotreplace": "42.120.000 €"
},
{
"price":"42",
"donotreplace": "42.120.000 €"
},
{
"price":"42€",
"donotreplace": "42.120.000 €"
},
]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)