# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/({\n\s*)(?:[^}{]*)(\n\s*{)/\1ZZZZZ\2/gim;t' <<< "{
\"0000\" \"1111\"
1111
{ 222 }
{ 333 }
}
{
test
{
nope
}
}
{
Hello?
{
Yes
{
This is dog
}
}
}"