use strict;
my $str = '{
"0000" "1111"
1111
{ 222 }
{ 333 }
}
{
test
{
nope
}
}
{
Hello?
{
Yes
{
This is dog
}
}
}';
my $regex = qr/({\n\s*)(?:[^}{]*)(\n\s*{)/imp;
my $subst = '\\1ZZZZZ\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";