$re = '/({\n\s*)(?:[^}{]*)(\n\s*{)/im';
$str = '{
"0000" "1111"
1111
{ 222 }
{ 333 }
}
{
test
{
nope
}
}
{
Hello?
{
Yes
{
This is dog
}
}
}';
$subst = "\1ZZZZZ\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;