import Foundation
let pattern = #"({\n\s*)(?:[^}{]*)(\n\s*{)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
{
"0000" "1111"
1111
{ 222 }
{ 333 }
}
{
test
{
nope
}
}
{
Hello?
{
Yes
{
This is dog
}
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1ZZZZZ\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)