package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)({\n\s*)(?:[^}{]*)(\n\s*{)`)
var str = `{
"0000" "1111"
1111
{ 222 }
{ 333 }
}
{
test
{
nope
}
}
{
Hello?
{
Yes
{
This is dog
}
}
}`
var substitution = "\1ZZZZZ\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}