#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)({\n\s*)(?:[^}{]*)(\n\s*{)"
Local $sString = "{" & @CRLF & _
" "0000" "1111"" & @CRLF & _
" 1111" & @CRLF & _
" { 222 }" & @CRLF & _
" { 333 }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"{" & @CRLF & _
" test" & @CRLF & _
" {" & @CRLF & _
" nope" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"{" & @CRLF & _
" Hello?" & @CRLF & _
" {" & @CRLF & _
" Yes" & @CRLF & _
" {" & @CRLF & _
" This is dog" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"}"
Local $sSubst = "\1ZZZZZ\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)