// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)({\n\s*)(?:[^}{]*)(\n\s*{)").unwrap();
let string = "{
\"0000\" \"1111\"
1111
{ 222 }
{ 333 }
}
{
test
{
nope
}
}
{
Hello?
{
Yes
{
This is dog
}
}
}";
let substitution = "\\1ZZZZZ\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}