#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\w+): (.*)\n\1: "
Local $sString = "abc: bla1 bla1 bla1..." & @CRLF & _
"abc: bla2 bla2 bla2..." & @CRLF & _
"bcd: bla bla bla..." & @CRLF & _
"cde: bla bla bla..." & @CRLF & _
"ghk: bla1 bla1 bla1..." & @CRLF & _
"ghk: bla2 bla2 bla2..." & @CRLF & _
"lmn: bla bla bla..." & @CRLF & _
"xyz: bla bla bla..." & @CRLF & _
""
Local $sSubst = "\1: \2 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)