$re = '/^(\w+): (.*)\n\1: /m';
$str = 'abc: bla1 bla1 bla1...
abc: bla2 bla2 bla2...
bcd: bla bla bla...
cde: bla bla bla...
ghk: bla1 bla1 bla1...
ghk: bla2 bla2 bla2...
lmn: bla bla bla...
xyz: bla bla bla...
';
$subst = "\1: \2 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;