import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w+): (.*)\\n\\1: ";
final String string = "abc: bla1 bla1 bla1...\n"
+ "abc: bla2 bla2 bla2...\n"
+ "bcd: bla bla bla...\n"
+ "cde: bla bla bla...\n"
+ "ghk: bla1 bla1 bla1...\n"
+ "ghk: bla2 bla2 bla2...\n"
+ "lmn: bla bla bla...\n"
+ "xyz: bla bla bla...\n";
final String subst = "\\1: \\2 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}