use strict;
my $str = 'abc: bla1 bla1 bla1...
abc: bla2 bla2 bla2...
bcd: bla bla bla...
cde: bla bla bla...
ghk: bla1 bla1 bla1...
ghk: bla2 bla2 bla2...
lmn: bla bla bla...
xyz: bla bla bla...
';
my $regex = qr/^(\w+): (.*)\n\1: /mp;
my $subst = '\\1: \\2 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";