using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\w+): (.*)\n\1: ";
string substitution = @"\1: \2 ";
string input = @"abc: bla1 bla1 bla1...
abc: bla2 bla2 bla2...
bcd: bla bla bla...
cde: bla bla bla...
ghk: bla1 bla1 bla1...
ghk: bla2 bla2 bla2...
lmn: bla bla bla...
xyz: bla bla bla...
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}