package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<span><img (id=\"([^"]*)\").*><\/span>`)
var str = `<section>
<span><img id="id1" src="src" alt="alt"></span>
<span><img id="id2" src="src" alt="alt"></span>
</section>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}