re = /<span><img (id=\"([^"]*)\").*><\/span>/
str = '<section>
<span><img id="id1" src="src" alt="alt"></span>
<span><img id="id2" src="src" alt="alt"></span>
</section>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end