import Foundation
let pattern = #"<span><img (id=\"([^"]*)\").*><\/span>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<section>
<span><img id="id1" src="src" alt="alt"></span>
<span><img id="id2" src="src" alt="alt"></span>
</section>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}