# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[CDATA\[\[[^]*?]]>//gm;t' <<< "<records>
<record>
<name>Jon</name>
<surname>Doe</surname>
<dob>2001-02-01</dob>
<comment>
<![CDATA[[ Patient with > 2 and < 5 siblings]]]>
</comment>
</record>
<record>
<name>Jane</name>
<surname>Doe</surname>
<dob>2001-02-01</dob>
<comment>
<![CDATA[[ Patient with > 2 siblings ]]]>
</comment>
</record>
</records>"