import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[CDATA\\[\\[[^]*?]]>";
final String string = "<records>\n"
+ " <record>\n"
+ " <name>Jon</name>\n"
+ " <surname>Doe</surname>\n"
+ " <dob>2001-02-01</dob>\n"
+ " <comment>\n"
+ " <![CDATA[[ Patient with > 2 and < 5 siblings]]]>\n"
+ " </comment>\n"
+ " </record>\n"
+ " <record>\n"
+ " <name>Jane</name>\n"
+ " <surname>Doe</surname>\n"
+ " <dob>2001-02-01</dob>\n"
+ " <comment>\n"
+ " <![CDATA[[ Patient with > 2 siblings ]]]>\n"
+ " </comment>\n"
+ " </record>\n"
+ "</records>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}