using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[CDATA\[\[[^]*?]]>";
string substitution = @"";
string input = @"<records>
<record>
<name>Jon</name>
<surname>Doe</surname>
<dob>2001-02-01</dob>
<comment>
<![CDATA[[ Patient with > 2 and < 5 siblings]]]>
</comment>
</record>
<record>
<name>Jane</name>
<surname>Doe</surname>
<dob>2001-02-01</dob>
<comment>
<![CDATA[[ Patient with > 2 siblings ]]]>
</comment>
</record>
</records>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}