# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[CDATA\[\[[^]*?]]>"
test_str = ("<records>\n"
" <record>\n"
" <name>Jon</name>\n"
" <surname>Doe</surname>\n"
" <dob>2001-02-01</dob>\n"
" <comment>\n"
" <![CDATA[[ Patient with > 2 and < 5 siblings]]]>\n"
" </comment>\n"
" </record>\n"
" <record>\n"
" <name>Jane</name>\n"
" <surname>Doe</surname>\n"
" <dob>2001-02-01</dob>\n"
" <comment>\n"
" <![CDATA[[ Patient with > 2 siblings ]]]>\n"
" </comment>\n"
" </record>\n"
"</records>")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.